Trial site, a couple of issues & a big Thankyou

Jan 10, 2008 at 10:49 PM
Well Thanks heaps people for starting this project. I was just looking for a way to introduce photos to my daughter's site when I came across your post in the blogengine.net discussions and thought why not give it a go. She has agreed to be a guinea pig & loves it so far - here's the address: http://rose.zetatech.com.au. There were a couple of show stoppers which I fixed before she could get going.

The first was the ordering of the posts, they were coming out in random order, so I added
PostList1.Posts.Sort();
after line 43 of the Page_Load method of default.aspx.cs

The 2nd thing was the inability to delete posts, I found that replacing
Request.QueryString["delete"]
with
Request.QueryString["deletepost"]
in post.aspx.cs fixed that.

There are a couple of other little things we've noticed straight away, but you're probably already aware of them:
  1. [polaroid:album-name] produces a polaroid for all albums, ditto slideshow
  2. The polaroids don't work in IE after a refresh
  3. can't delete photos, get a "file in use" error

I realise this project is very very new but as I said my daughter's quite happy to give it a trial.
Looking forward to following your progress.
Coordinator
Jan 11, 2008 at 12:33 AM
Thanks for trying out BE Photo. We'll work on fixing the bugs you have reported.

Do you remember which change set # you downloaded? I believe the "file in use" error when deleting photos has been fixed.
Jan 11, 2008 at 1:06 AM
It was 5719.